API is crashing
Resolved
Jul 17 at 12:42pm EDT
The issues have been resolved. We are monitoring for other errors, OnClock should be fully available.
The downtime and the previous ones were caused by a bad authentication token submitted by a client. We had a bug were we didn't escape this error properly and it would crash the entire API. We apologize for the inconvenience and we will make sure this doesn't happen again.
Affected services
OnClock REST API
OnClock Bot
OnClock Web Application
Updated
Jul 17 at 12:23pm EDT
API is working again, but the bot doesn't recognize it. We are working on fixing this.
Affected services
OnClock REST API
OnClock Bot
OnClock Web Application
Created
Jul 17 at 11:20am EDT
Our API is crashing over and over. We are investigating and have created a fix to solve this issue.
Affected services
OnClock REST API
OnClock Bot
OnClock Web Application